MungBeans

Hi There,

It seems that every time I am trying to startup my Spine, it stays on the splash screen. I pinpoint the issue to my preference files :think:, at the moment I need to delete the preference file every time in order to load startup spine. I have tried adding Spine as an exception to my anti-virus and that did not work.

STEPS
1) Using my attached preference file, startup Spine
2) The splash screen appears.

OBSERVED BEHAVIOR
The splash screen stays in place and Spine doesn't load up.

EXPECTED BEHAVIOR
Spine should load up as per normal with my preference file in place.
Note: in order for me to start Spine I need to delete the preference file everytime.

Here are my attached logs, and also my preference file:
prefs.json

spine.log
Bạn không được cấp phép để xem tập tin đính kèm trong bài viết này.
MungBeans
  • Bài viết: 2

Nate

Thank you for the detailed report! It's so nice: reproduction steps, actual behavior, expected behavior, the relevant log and settings files, what you tried so far. :sogood: Please teach everyone else how to report issues! :grinteeth:

A few other users have reported similar behavior, though usually reported that Spine runs once then they need to reinstall (which resets prefs.json) to run again. Unfortunately we have not been able to reproduce the issue.

Nothing stands out as being problematic in your prefs.json file. The one thing that may be related is:
"monitor":1,
Can you please try deleting this value? This is the monitor index for the monitor Spine was on when the file was saved. It is used to open Spine on the same monitor. It may be that something about doing that fails and the Spine windows isn't created successfully. When the Spine window is shown, it hides the launcher window, so it seems the failure prevents Spine from getting that far. It is very odd that the failure is silent.

If deleting the value allows Spine to run, you can change the value to:
"monitor":-2,
This will prevent Spine from trying to reopen the Spine window on a particular monitor. Instead it will always open on the primary monitor.

Before setting to -2 though, it would be helpful if we can find some more information about the problem. If you delete the prefs.json file, run Spine, then close it without it being maximized of full screen, does it run the second time? My thinking is maybe the maximized, non-maximized, or full screen state of the window is relevant, as when Spine runs it tries to create the window in the same state it had when closed.

I wonder what could be different about your multiple monitor setup that causes the problem, as we don't see it on ours. What graphics card are you using? Do you have the latest drivers? Can you think of anything that could be unique about your setup?

BTW, I see you are running 3.8.72. The last few 3.8 releases have some important fixes for stability. We've just released 3.8.97.
Hình đại diện của thành viên
Nate

Nate
  • Bài viết: 9847

MungBeans

haha thank you for the report complement, I actually have been working as QA in software for a very long time, so I know how it feels when you don't get a clear bug report ;).

The monitor trick in the preference file worked, looks like getting rid of that line for monitors worked and changing the value to -2, solved my issue :).

Here is my setup details:
- Using a Windows 10 laptop with RTX 2070 graphics card that uses a secondary monitor which is an Apple Retina display.
- I do use spine on the secondary monitor for more space :).
- I have the latest Graphics card drivers.

Maximized Window Test
- I get the issue regardless of max or minimized window, when Spine is on the secondary monitor (Apple Retina)
- I don't get the issue for both max and minimized window, when Spine is on the primary laptop screen.

Cheers again for helping out :)
MungBeans
  • Bài viết: 2

Nate

Great, glad that worked, though I wish we could reproduce it or at least find more clues. We've tried similar setups but Spine reopens on the second display just fine here. Tried different monitors, though don't have an Apple Retina monitor. Tried making the secondary left/right/above/below the other. There's got to be something different that causes the problem for you. :(
Hình đại diện của thành viên
Nate

Nate
  • Bài viết: 9847


Quay về Editor